I suggest you ...

Add Google pagespeed integration

574 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Thomas shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    102 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Dirk Liesenfeld commented  ·   ·  Flag as inappropriate

        @Tozz
        That is absolutely not true. Plesk could easily integrate mod_pagespeed into nginx. Sure it is possible to solve that directly on the server, but in that case you wouldn't need plesk at all. So - for many people it is a very big request to add google pagespeed into nginx. If you do not need it: good for you ;-)
        Btw., http2 is running perfectly on my plesk-hosted server, you seem to mix something up there.

      • Tozz commented  ·   ·  Flag as inappropriate

        The comments here about 'We need it now' are rants and useless.

        PageSpeed or HTTP/2 integration has nothing to do with Plesk or Parallels. It has to do with support in your webserver. Most Distributions do not yet support HTTP/2.

        For example, Debian 8 has no HTTP/2 support in Apache.

        It is not Plesk that needs to fix things, you need to wait for a distribution that has support for HTTP/2 and then enable its module.

      • Dirk Liesenfeld commented  ·   ·  Flag as inappropriate

        This topix was started 5 years ago. 3 years ago the admin promised to implement it. NOTHING has happened since then. It has 520 voices already. Please do something FAST!
        @admin: what is the status?

      • Anonymous commented  ·   ·  Flag as inappropriate

        Guys! What are you waiting for? Pagemode dir Apache and Ngnix NOW! It ist really about time...

      • John Shiells commented  ·   ·  Flag as inappropriate

        caution: adding mod_pagespped breaks websites when NGINX is proxy. you have to turn off static file processing by NGINX.

        This is not really a solution Plesk people :) Nginx pagespeed needs to be used instead of the one for Apache.

      • Daniel Hendricks commented  ·   ·  Flag as inappropriate

        I would like to see this as well. I would be concerned about static HTM(L) files.

        Currently, when mod_pagespeed is enabled in Plesk for Apache, HTM/HTML files come up blank. The recommended fix is to "Serve [htm/html] files directly by nginx" to bypass.

        It's pretty ugly as it breaks the default Plesk new web site skeleton pages (most of which have .html extensions). There is nothing like signing up for new hosting and you are greeting with a white page (I fixed it by renaming the .html files to .php and advise users to serve .htm(l) files through nginx, but that's not really a "fix").

      • B_P commented  ·   ·  Flag as inappropriate

        One feedback about the Plesk extension: It is necessary to enable a re-evaluation of every site!

      • Viktor Vogel commented  ·   ·  Flag as inappropriate

        The PageSpeed Insights extension now supports the installation of the Apache module in version 1.1.0 - https://ext.plesk.com/packages/3d2639e6-64a9-43fe-a990-c873b6b3ec66-pagespeed-insights

        The support of the Nginx module is not possible with the extension since you have to manually (re-)compile Nginx with the PageSpeed module. The delivered Nginx binary by Plesk does not contain the PageSpeed module.

        This tutorial might help you if you want to install PageSpeed manually in Nginx: https://talk.plesk.com/threads/install-page-speed-google-nginx.335615/#post-790194

      • Hasib commented  ·   ·  Flag as inappropriate

        Plesk Please Please Please add Google page module. It has been many years since you behind others

      • Anonymous commented  ·   ·  Flag as inappropriate

        Please include to Plesk nginx version with ngx_pagespeed module integrated and probably some dashboard options for enabling it and dssabling and adding rules.

      • JV commented  ·   ·  Flag as inappropriate

        Hello, I am also seeing the error with Cloudflare enabled. All my clients are using Cloudflare so the tool is useless in this moment.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I'm seeing this error as well using CloudFlare. Domain is not active or IP address does not resolve properly. Please select an active domain!

      Feedback and Knowledge Base