Feature Suggestions

Please provide here your suggestion for new functionality for Plesk. We encourage you to review and vote for suggestions of others. The top-ranked suggestions are likely to be included in the next versions of Plesk.

Please write in English so that voters from all over the world can read and support your request.

For technical assistance, contact Plesk support
For questions, bug reports, discussions and free assistance, check our Forum and Facebook page
For additional information, see Documentation, Knowledge Base and Blog
Follow us on Twitter for more news on Plesk development

Off-topic posts will be removed from here

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Add support for net core 3.0 for linux and windows plesk

    Net core can run applications on windows and linux with a short configurations . Please add support to both OS

    1,094 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    188 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  2. Add IIS App Pool start/stop and recycle permissions separately from enable permission

    At the moment there is only one permission for IIS App Pool Management.

    It would be interesting if a subscription had the permission to start/stop or recycle their dedicated App Pools, but not to create new ones.

    In this scenario, there would be an option to provide the subscription with a single App Pool, and let them manage it, but not to create new App Pools.

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  3. Support for JDK Temurin-17

    Add support for jdk temurin-17 on Plesk servers.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  4. add sprut.io web file manager

    add sprut.io web file manager

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  5. Chose the database server when installing an application from the Aps Catalog

    Option to select any of the database servers setup in Plesk when installing an application from the Aps Catalog,

    Currently, the database server chosen by the aps catalog is the default one on the subscription set in the service plan.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  6. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  7. Add the ability to log/monitor incoming traffic for a certain application/port

    Currently I have a Node JS Application built for a website example.com responding to CoAP Requests on a customer port, e.g. 5678.
    It would be great if I could log or monitor incoming UDP requests for this port similar to how the 'Apache SSL/TLS access' show.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  8. Add "Custom Environment Variable" option on NodeJS for Windows

    Add "Custom Environment Variable" option on NodeJS for Windows - It's currently available on Linux, only.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  9. Why does Plex Onyx contains extremely outdated conrete5 Version v5.7.3

    concrete5 v5.7.3 is more than 6 years old and won't install on a current PHP-Version. Please make the current version 8.5.4 available!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  10. Upgrade auf Coppermine 1.6 must be made available

    Please add the possibility to update Coppermine 1.5.X to Coppermine 1.6.X via Plesk.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  11. Update Plesk PHP against a newer version of libicu package

    Plesk PHP handlers should have the latest libicu package version for better compatibility with newer versions of web apps such as Magento

    11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    open discussion  ·  1 comment  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  12. Disable PHP's open.base_dir restriction by default

    Every configured hosting/website gets their proper own user with their own permissions. If you run your website with the PHP-FPM handler, the processes properly run with this very user.
    Why is there still open.base_dir restrictions applied by default? I don't really see the point.

    Why am I asking? Enabling open.basedir has a massively (!) negative impact on performance. PHP's internal realpath cache is automatically disabled when open.basedir is activated which slows down all the file operation calls tremendously.
    As the user permissions are properly set up, this is imho a missed opportunity for free performance gains.

    Sources:

    • Does…
    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  13. Add support for the Cluster module in Passenger

    Add support for the Cluster module in Passenger supplied with Plesk:
    https://nodejs.org/api/cluster.html#cluster_cluster

    Currently, when Node Cluster module is called on a NodeJS application configured in Plesk in development mode, the following error is be shown:

    Trace: You required the Node Cluster module, which is incompatible with Passenger, a non-functional shim was returned and your app may still work. However, please remove the related code as soon as possible.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  14. Github Actions CI/CD for deploy

    Hi.
    Now that Github has CI/CD through Workflow Actions, It would be nice to have an official plesk deployer.
    There is already a FTP uploader, but it would be nice to have something from Plesk for IIS deploy, with config variable transformation, etc.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  15. Magento 2.3.4 support

    It would be good to add Magento 2.3.4 support to Plesk with all needed compatibility adjustments (such as PHP handlers update).

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  16. The MediaWiki version currently installable through Plesk is outdated

    In Plesk 17.8.11, the MediaWiki version currently available is 1.31.0, which is outdated. The long-term support version is at 1.31.6, and the most recent one at 1.34.0, see https://www.mediawiki.org/wiki/Download.

    Please consider updating the installer.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  17. wanted to see SQL Server health performace

    as mssqlplanner.com provides their Several analytic report free
    like Space analysis, DB level analysis , CPU, RAM , Query level

    It will be worth to customer to have such report to see how is database server performance now and they will be able to know when they should buy higher resource with big rock

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  18. Integrate Snaps

    It would be great if we could install Snaps (Containerized applications from Canonical) from Plesk. Things like Rocket.Chat would be one-click installs from there

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  19. Wildfly support

    Implement http://www.wildfly.org/ instead of deprecated Tomcat

    Created according to the comment from this article https://support.plesk.com/hc/en-us/articles/360000322173?page=1#comment_360000633734

    93 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    38 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
  20. Matomo (new PIWIK)

    PIWIK is death!
    Simple Matomo-plug-in installation without additional configuration for the databases or the host

    391 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    31 comments  ·  Web Applications  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3
  • Don't see your idea?

Feedback and Knowledge Base