I suggest you ...

Allow whitespace in (administrator) passwords and if you don't give proper feedback.

If I enter an administrator password with whitespace in it, it seems to be accepted but isn't actually applied.

3 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Christian BChristian B shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Christian BChristian B commented  ·   ·  Flag as inappropriate

        Actually, if I change users's password via passwd on the server itself instead of using the Plesk interface, I can use whitespace in passwords. As said, if I try the same via the Plesk interface there's no feedback that the password wasn't accepted. The entered password is actually rated as strong or very strong. There doesn't seem to be any validation before the new password is applied (which apparently fails silently). The restrictions on password are certainly documented in the manual. However, why isn't this information directly in the web interface? Last but not least, I don't see the point of disallowing whitespace in passwords at all.

      Feedback and Knowledge Base