Feature Suggestions

Please provide here your suggestion for new functionality for Plesk. We encourage you to review and vote for suggestions of others. The top-ranked suggestions are likely to be included in the next versions of Plesk.

Please write in English so that voters from all over the world can read and support your request.

For technical assistance, contact Plesk support
For questions, bug reports, discussions and free assistance, check our Forum and Facebook page
For additional information, see Documentation, Knowledge Base and Blog
Follow us on Twitter for more news on Plesk development

Off-topic posts will be removed from here

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. add option to have dedicated php instance on a domain alias

    I have noticed that on main domains and subdomains this is a option but when you add a domain alias this option does not seem to be there.

    I would think this would be something useful to have especially if you are like us and have multiple domain alias pointing to one main site for files but wanting separate domains under one account like for us it is multiple ecommerce websites.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    open discussion  ·  1 comment  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Changing the PHP default version of every newly created domain, regardless of the service plan feature.

    An option that allows new domains to be created with a default PHP version other than the current Plesk default PHP version would allow, for example, Web Admin licenses to automatically newly created WordPress instances with custom installations such as specific plugins/themes to be created with a PHP version compatible with their specific architecture.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. AVIF support

    Can you please prepare GD library with AVIF support.

    It is supported from PHP version 8.1

    https://php.watch/versions/8.1/gd-avif

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. PHP 8 - HEIC ImageMagick 7 support

    As HEIC is the default format for photos on iOs devices, il would be great to be able to upload heic images on website and to work with using php.

    It is not possible, and acceptable, to ask to final user to convert there images to jpg before uploading. Most of them will not understand about what we are talking.

    As I understand heic is already supported by ImageMagick, il is just an option to trigger when compiling.

    13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Bring support for Open Swoole in PHP

    Open Swoole will allow us to bring PHP development to next level! Its will support true concurrency and will can be used to bring php to all kinds of new and exiting applications: websocket, webrtc, tcp, udp etc...

    Build high-performance, scalable, concurrent TCP, UDP, Unix Socket, HTTP, WebSocket services with PHP and easy to use coroutine, fibers API

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Manage PHP-FPM status path and additional PHP-FPM settings globally

    For our monitoring environment we want to use the pm.status_path, ping.path and ping.response settings for all PHP-FPM pools globally.

    At the moment the only way to set these settings is by adding the following in Domain -> PHP Settings -> Additional configuration directives:
    [php-fpm-pool-settings]
    pm.status_path = /php-fpm-status
    ping.path = /php-fpm-ping
    ping.response = pong

    Unfortunately there is no way to set this globally, not by changing the plan nor by utilizing event handlers (because we're unable to set this through /usr/local/psa/bin/php_settings -u).

    I've also been unable to find the template for the PHP-FPM pool settings, so also unable to change this…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Code Editor: Multiple Tabs, and Code Folding

    1) In the past could open multiple tabs of files for Code Editor, it was nice.

    2) Is there a chance to have code folding for functions inside code editor?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. PHP Extensions Installer

    I would love to see PHP Extensions Installer like other panels cPanel and DirectAdmin have it. Can we see a feature where we install needed PHP Extensions from Plesk rather than SSH into server and install?

    15 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Add SSH2 extension to PHP default extensions to improve security

    Hi,

    Please consider add SSH2 extension to PHP default available extensions.

    To be able to use FTP over SSH (SFTP) the SSH2 extension must be installed on PHP.

    IN SHORT: SFTP (SSH2 EXTENSION) = SECURITY

    SFTP means secure file transfer via Secure Shell (or SSH), hence the name SSH File Transfer Protocol (SFTP). The two devices (server and client) communicate via a single channel, that of SSH, in which the remote file management commands are sent and where the file transfer takes place. By default, the only port required for SFTP is 22, the same as SSH.

    SFTP implements the…

    29 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. get Sodium support for PHP

    We could do with the power of the Sodium crypto libraries to prevent the vulnerabilities created by weak key protection.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. Code Editor

    the Code Editor is now 900px wide. why? I need it across the entire page 100% wide

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Add support of ImageMagick7 for PHP shipped by Plesk

    Would be great to use ImageMagick7 with PHP versions shipped by Plesk.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. GraphicsMagick support

    ImageMagick look nearly dead(?) https://pecl.php.net/package/imagick no progress in months (years) and no official lib for PHP 8.

    GraphicsMagick is fully under development https://pecl.php.net/package/gmagick

    So I wish support for gmagick in Obsidian ;)

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. to make a button to reset your Composer-settings for your site.

    If you have a webpage set up with composer, and delete the project, the composer-settings remain stuck on the old composer file. Please make a button to reset this.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Hide only PHP-FPM settings for domain.

    It would be nice to have ability to prevent client from modifying the number of maxchildren . The permission "Hosting performance settings management " revokes this but it also prevents the user from changing PHP options like execution time and maxvars. But we would like to allow our clients to manage "Performance and security settings" parameters in Plesk.

    9 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Add mcrypt module to Plesk PHP 7.2 and newer

    Add mcrypt module to Plesk PHP 7.2 and newer.
    For previous PHP versions it's included out of the box.

    Mcrypt 1.0.2 natively supports PHP 7.2+ (https://pecl.php.net/package/mcrypt/1.0.2)

    It's, for example, required by Prestashop 1.7.x, which is quite popular among Plesk users.

    103 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. Update phpredis to a newer version

    The bundled phpredis version was released back in june of 2016. Currently (may 2020) the most recent version is 5.2.1. Please update this php module to improve compatibility and performance.

    Manual guide can be found here:
    https://stackoverflow.com/questions/58613266/install-redis-on-plesk-onyx-centos-and-update-phpredis

    12 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Awstate update to supports Geoip registration

    As AWstat is still core part of Plesk, will it be good to have a solution out-of-the-box that is able to geolocalize the hits isn't it ?

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. 12 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Thank you for your input! We will consider this functionality in upcoming releases if it will be popular. Everyone, please continue voting for this feature if you consider it important.

    Since MongoDB driver is not included in Plesk PHP packages, it could only be installed manually with help of this KB article:

    https://support.plesk.com/hc/en-us/articles/213916565-How-to-install-PHP-MongoDB-driver-for-Linux-


    IG

← Previous 1
  • Don't see your idea?

Feedback and Knowledge Base