Feature Suggestions

Please provide here your suggestion for new functionality for Plesk. We encourage you to review and vote for suggestions of others. The top-ranked suggestions are likely to be included in the next versions of Plesk.

Please write in English so that voters from all over the world can read and support your request.

For technical assistance, contact Plesk support
For questions, bug reports, discussions and free assistance, check our Forum and Facebook page
For additional information, see Documentation, Knowledge Base and Blog
Follow us on Twitter for more news on Plesk development

Off-topic posts will be removed from here

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Upgrade Ubuntu 16.04 to 18.04 and / or 20.04

    I want to upgrade Plesk 18 from Ubuntu 16.04 to Ubuntu 18.04 or 20.04.

    As described here: https://support.plesk.com/hc/en-us/articles/360002913773-Ubuntu-18-04-support-in-Plesk

    271 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    94 comments  ·  Migrations  ·  Flag idea as inappropriate…  ·  Admin →

    I’m glad to inform you that today we finally published dist-upgrade instructions for Plesk Obsidian.

    Using this instruction server administrator can perform Operation System upgrade together with Plesk Obsidian.

    Supported dist-upgrade paths:

    Debian 9 to Debian 10
    Ubuntu 16 to Ubuntu 18
    Ubuntu 18 to Ubuntu 20

    Note: Debian 8 → Debian 9 dist-upgrade path is not in the supported list.

    Dist-upgrade chapter in Plesk Obsidian documentation: https://docs.plesk.com/en-US/obsidian/administrator-guide/server-administration/distupgrade-support.74627/

    KB article with the particular instructions: https://support.plesk.com/hc/en-us/articles/213410369

  2. Ability to add MX DNS record with a custom priority from Plesk GUI

    Currently, MX record the dropdown priority options are available at an interval of "5".

    However, Google Mail and G-Suite require to create MX-record with a priority 1, which is not available in Plesk.

    There is similar request here https://talk.plesk.com/threads/google-mail-dns-wont-validate-unless-mx-priority-is-1.357702/

    Please, add ability to set other MX priorities in Plesk interface.

    20 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  Usability and UI  ·  Flag idea as inappropriate…  ·  Admin →
  3. Mod Security v3.x.x (aka libmodsecurity) for NGINX and Apache

    Hi,

    Please consider implementing Mod Security v3.x.x (aka libmodsecurity) for NGINX and Apache in the next Plesk update.

    At the moment any Plesk user if he wants to use Mod Security (official version supported by Plesk) is forced to use it as a web server:


    • Apache

    or


    • Apache + NGINX

    Any Plesk user who wants to use only NGINX as a web server and without using Apache at the moment cannot use Mod Security because Plesk does not currently support it for NGINX exclusively web servers.

    Here are some of the advantages of Mod Security v3.x.x (aka libmodsecurity and these…

    15 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Security  ·  Flag idea as inappropriate…  ·  Admin →
  4. Add the possibility to define which theme will be set by default after the WordPress installation

    For example when we add the required theme into the WordPress set, after the installation the "Twenty Twenty" theme will be set as default.

    Please add the possibility to define which theme will be set by default after the WordPress installation as via the CLI method as via Plesk GUI.

    The CLI method is important here because some customers use only this method for a WordPress installation.

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  WordPress Toolkit  ·  Flag idea as inappropriate…  ·  Admin →

    We have released this feature in WPT 5.2 update. You can use GUI or CLI to choose a theme that should be activated upon the installation of a set.

    CLI command example: plesk ext wp-toolkit —sets -operation activate-theme -set-id ID -theme-id THEME_ID
    If you’re using GUI, go to Sets and click on “+ Add Themes” button next to the corresponding theme.

    Let us know on our forum (talk.plesk.com) if you encounter any issues.

  5. .net 5.0 support

    you currently have 3.1 add support for .net 5.0 now that its released.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Web  ·  Flag idea as inappropriate…  ·  Admin →
  6. cloudlinux 8

    Hello,

    Please consider support of CloudLinux 8 on Centos 8 + Plesk.

    CloudLinux 8 is ready for production use now:
    https://blog.cloudlinux.com/cloudlinux-8-with-4.18-kernel-is-ready-for-production

    24 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Plesk (general)  ·  Flag idea as inappropriate…  ·  Admin →
  7. Ubuntu Pro support

    I'm wondering if it's possible to install Plesk on Ubuntu Pro 18.04 ?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Plesk (general)  ·  Flag idea as inappropriate…  ·  Admin →
  8. Translate Plesk to persian language

    Hi

    We Have about 180 million Persian language people in the world

    But Plesk does not have Persian language

    I want to translate plesk to persian Language

    Can You Help Me ?

    Thanks

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Plesk (general)  ·  Flag idea as inappropriate…  ·  Admin →
  9. Change settings for mail autodiscover

    Ability to change settings in the mail autodiscover - for example, to set the mail server that will be set in the mail client.

    45 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    11 comments  ·  Mail  ·  Flag idea as inappropriate…  ·  Admin →
  10. Disable or limit the backups of Wordpress toolkit

    Implement the ability to disable the backups of Wordpress toolkit, or limit the amount of backups that a domain user can do within this extension.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  WordPress Toolkit  ·  Flag idea as inappropriate…  ·  Admin →
  11. Update WP-CLI version on plesk ext wp-toolkit --wp-cli

    Current version ov WP-CLI with the command plesk ext wp-toolkit --wp-cli is 1.4
    the latest release is 2.4.1. please update that 3+ years old version!

    thanks

    12 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  WordPress Toolkit  ·  Flag idea as inappropriate…  ·  Admin →
  12. Update of paid WordPress plugins via WordPress Toolkit

    As you know, WordPress Toolkit can update plugins and themes installed only from WordPress.org. Paid plugins installed from vendors' websites cannot be updated using WordPress Toolkit.
    It's not convenient to update plugins from WordPress.org in the WordPress Toolkit and log into WordPress admin dashboard to update paid ones, so please implement this feature.
    Especially considering that it's possible to update both free and paid plugins in the WP dashboard (in the menu "Updates").

    13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  WordPress Toolkit  ·  Flag idea as inappropriate…  ·  Admin →

    WordPress Toolkit 4.7 now can update paid plugins & themes, if these updates are available in the WordPress admin area. Note that certain plugins and themes do not support automatic updates, but display notifications about update availability anyway. This particulal scenario isn’t fully supported yet.

    —AK

  13. Cross-platform migrations of the e-mails

    Add the ability to perform cross-platform migrations of the emails even for external 3rd party mail services.
    For now, it is only possible to use "Mail Importing" feature of the Site Import extension but it only migrates one mailbox at a time.
    The alternative way is to use 3rd party IMAP migration tools to copy email content, or copy it manually but this operation was not tested by Plesk.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Migrations  ·  Flag idea as inappropriate…  ·  Admin →
  14. Add PHP 8

    Please add PHP 8 to the plesk infrastructure

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Web / PHP  ·  Flag idea as inappropriate…  ·  Admin →
  15. WordPress Toolkit: Reseller Plans to use individual sets

    A a reseller I would like to be able to create my own specific plug-in 'sets' for my WordPress customers. Normally this should be done at this level, not by the 'top level' administrator.

    Maybe it is possible to use the same tab and visualize created sets from resellers with an icon.

    70 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  WordPress Toolkit  ·  Flag idea as inappropriate…  ·  Admin →

    Once upon a time we have released sets for resellers in WPT v5.2 a couple of minutes ago.

    We’ve also managed to ensure that resellers can automatically provision WordPress with one of their sets when a new subscription is created.

    Let us know on our forum if you have any feedback.

    —AK

  16. Centos 8 support

    On 24 Sep 2019 Centos 8 was released.

    https://blog.centos.org/2019/09/centos-8-and-centos-stream-released/

    This is a long time waited release because it brings
    a lot of useful features for web hosting performance and security

    https://access.redhat.com/documentation/en-us/redhatenterpriselinux/8/html/8.0release_notes/index

    20 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    11 comments  ·  Plesk (general)  ·  Flag idea as inappropriate…  ·  Admin →
  17. Support for Roundcube 1.4 (includes responsive support)

    I've installed 1.4 manually and it works without problems.

    52 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    38 comments  ·  Mail  ·  Flag idea as inappropriate…  ·  Admin →
  18. Easy removal X-Powered-By HTTP headers

    By default the HTTP header 'x-powered-by: PleskLin' is added to HTTP responses.
    And with PHP, even the version number is included: 'x-powered-by: PHP/7.3.5'

    For security it is better to not give such information, as it may expose you are using outdated software with known vulnerabilities.
    Currently it is possible to remove these headers, but it requires some manual actions using SSH (https://support.plesk.com/hc/en-us/articles/115000385274)

    My suggestion is to create page to be able to manage such header additions for all websites and services.

    76 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    12 comments  ·  Web / HTTP functions  ·  Flag idea as inappropriate…  ·  Admin →
  19. Implement MariaDB 10.4 support

    Please implement MariaDB 10.4 support. We have upgraded to MariaDB 10.4 by mistake and now we're jumping through hoops adding new websites / DB users.

    The main issue is that MariaDB have moved the 'user' table to a table called 'global_priv' and Plesk is still trying to read from the old one ( which they've converted into a View, so it errors out ).

    We can't downgrade, as it's not supported, and we certainly can't roll back. So it would be extremely awesome of you if you'd help with this.

    Also by reading on Reddit and Plesk Support forum, we're…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Databases  ·  Flag idea as inappropriate…  ·  Admin →
  20. ability to disable Wildcard certificate option in Let's Encrypt

    Add ability to disable Wildcard certificate option in Let's Encrypt

    18 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    14 comments  ·  Extensions  ·  Flag idea as inappropriate…  ·  Admin →

    Available since Let’s Encrypt Extension 2.8.3.

    https://ext.plesk.com/packages/f6847e61-33a7-4104-8dc9-d26a0183a8dd-letsencrypt

    “2.8.3 (24 October 2019)
    [+] Introduced the allow-wildcard-certificates option (true by default) under the ext-letsencrypt section in the panel.ini file. If set to false, the option hides the feature of issuing wildcard SSL/TLS certificates in the interfaces of the Let’s Encrypt and SSL It! extensions.

    Note: For the same purpose, users could earlier use the acme-protocol-version setting with the acme-v01 value. If you have this configuration, we recommend that you start using allow-wildcard-certificates set to false because the ACMEv1 protocol will soon reach end of life."

    — rk

← Previous 1 3 4 5 15 16
  • Don't see your idea?

Feedback and Knowledge Base