I suggest you ...

that you adapt the main domain name of an IP as the myhostname for POSTFIX or QMAIL.

Most of RBLS are checking the SMTP Banner and currently only the first domain name is being used. To reduce scamming or to prevent being blacklisted you should apply myhostname with the according domain name.

155 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Henning MöllendorfHenning Möllendorf shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    35 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • GaelGael commented  ·   ·  Flag as inappropriate

        Dito - impacting my clients on my server! each has a different IP address! ALL should be able to have their own SMTP banner - outlook.com is blocking emails beacuse of this!!! PLEASE FIX!

      • KevinKevin commented  ·   ·  Flag as inappropriate

        server name: example.com
        hostname: host.example.com
        RDNS: host.example.com
        HELO record: example.com

        Now I see that plesk implemented "Send from domain IP addresses and use domain names in SMTP greeting" under outgoing mail mode in the server mail setting.

        But I need the smtp greeting to be sent from hostname.example.com, not from the domain name.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Big issues myself now Plesk 12.5 and still not fixed? My postfix crapped on last update and had to switch back to qmail.

      • Manu-KManu-K commented  ·   ·  Flag as inappropriate

        @PleskStaff: Is this issue still not solved? Or am I missing something? 135 Votes should be enough to see that this is important...

      • Tim ReevesTim Reeves commented  ·   ·  Flag as inappropriate

        I agree with the very first comment on this thread: When an IP has a default domain, that domain should be used in the SMTP banner in place of the hostname. I see no reason why Plesk should not add a corresponding IP-Section to Postfix' master.cf

      • TozzTozz commented  ·   ·  Flag as inappropriate

        I would be interested in someone commenting with an example of what he/she wants to acomplish. Now comments are talking about RDNS, which most often cannot be managed by Plesk but needs to be managed by your ISP

        Can someone explain in detail what needs to be done?

      • MarkusMarkus commented  ·   ·  Flag as inappropriate

        Somebody wrote a workaround? I'm thinking in programming a cronjob with redes the mast.cf file created by plesk and change HELO name to main server name of the IP is the main IP. This should fix the problem from Plesk. Or someone has another idea?

      • Anonymous commented  ·   ·  Flag as inappropriate

        @Tozz We do not want the domain name, but the host name. The case also in Ideall Reverse DNS is the name and then it will come with multiple IP addresses per mail server to send to recipients who püfen the Reverse DNS / PTR.

      • Anonymous commented  ·   ·  Flag as inappropriate

        To fix the problem with shipping on the domain IP address, we bnötigen in Plesk DNS template the possibility PTR create entries that end not only to <domain>, but give us the opportunity here to use the Reverse DNS. In the second step must take the Helo Domain Name Hello RDNS come (postfix / main.cf). and already it works well with multiple domains per mail server. I will reply to the developers only in German, in English because you have not understood it, or want to understand.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I believe in Odin lack of understanding of the issue. If I have understood everything correctly, it goes firstly to the Reverse DNS mismatch and secondly, the problem goes DNS or the PTR record does not resolve when you use the IP domain of the reverse.

        In principle both is very easy to solve by Plesk.
        To fix the problem with the Reverse DNS mismatch, it requires only the possibility in DNS Template another A and AAAA create entry which then refers to the reverse DNS entry. What is currently not possible, as more and <domain> is specified for the A or AAAA DNS entry in Plesk template. Here there is no possibility an A or AAAA entry to create the looks for example: mx.rdns.xxx. Since Plesk always <domain> is specified it comes naturally to this reverse DNS mismatch.
        Try it for yourself: Put under / var / named / run-root / var the A and AAAA records and IP RDNS on and you will see, there is no DNA mismatch more. It is only available while Plesk nothing fundamental to denDNS template settings changes will not last. Because every time Plesk upgrade to standard DNS etc. entries will be lost.
        The rest is just as easy, but here can indeed times a Plesk developers contact me. But I answer only in German. :)

      • TozzTozz commented  ·   ·  Flag as inappropriate

        You should see this when running Plesk 12 on Linux with Postfix.

        But be aware: Blacklists such as cbl.abuseat.org will list your IP-addresses if they send mail using multiple EHLO/HELO hostnames.

        I can't stress this enough: You are misunderstanding the RBLs. You _dont_ want multiple HELO hostnames from 1 IP.

      • MatteoMatteo commented  ·   ·  Flag as inappropriate

        This should be fixed or, at least, a workaround should be given

        @Tozz: In my plesk installation i don't have this Tools & Settings -> Mail Server Settings -> Outgoing mail mode and i'm unable to apply this "You can choose to use the server name as HELO hostname or the domain's hostname." Can you give me more information, please? Thx

      • TozzTozz commented  ·   ·  Flag as inappropriate

        @mstefanem: Your rant is untrue. Although I agree that it wasn't properly documented that Plesk has changed the default setting with an update, you can change it quite easily:

        Tools & Settings -> Mail Server Settings -> Outgoing mail mode

        Outgoing mail mode is set to "Send from domain IP addresses and use domain names in SMTP greeting" probably. Change it to "Send from domain IP addresses"

      ← Previous 1

      Feedback and Knowledge Base